Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login | Reply
Loading... please wait.
  • by cjfields (3851) on 2009.10.22 21:10 (#70947) Journal

    It's a little touchy, but it does work using perl 5.10.1 (haven't tried 5.8.9 yet). Getting some warnings about missing DLLs during the test phase, primarily expat or libxml-related (not sure why).

    Also getting tons of 'Subroutine X redefined' warnings, which are pretty harmless but it would be nice to track down why they're popping up. These also occur when testing BioPerl with ActivePerl.

    • I think I know why the "missing DLL's" message pops up... Sometimes the Strawberry installer needs a log-out/log-back-in (a reboot works just as well) to register the path entries it adds to the environment - which it needs to find the dll's. I don't know how to determine when it happens, I just know that it happens.

      I noticed the "Subroutine redefined" errors, too. :)

      --
      The new Strawberry Perl for Windows has been released! Check http://strawberryperl.com for it.
      • I think I know why the "missing DLL's" message pops up... Sometimes the Strawberry installer needs a log-out/log-back-in (a reboot works just as well) to register the path entries it adds to the environment - which it needs to find the dll's. I don't know how to determine when it happens, I just know that it happens.

        Okay, good. May be worth a retry then.

        I noticed the "Subroutine redefined" errors, too. :)

        This also pops up via one of the CPAN Tester reports [perl.org]