Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login | Reply
Loading... please wait.
  • Checking if your kit is complete...
    Looks good
    Writing Makefile for Crypt::Rijndael
    cp Rijndael.pm blib/lib/Crypt/Rijndael.pm
    /opt/SUNWspro/bin/cc -c   -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DPERL_USE_SAFE_PUTENV -DPERL_USE_SAFE_PUTENV -O   -DVERSION=\"1.04\" -DXS_VERSION=\"1.04\" -KPIC "-I/tmp/bleadperl/lib/5.10.0/i86pc-solaris/CORE"   _rijndael.c
    "_rijndael.c", line 425: warning: integer overflow detected: op "<<"
    "_rijndael.c", line 464: warning: i

    • I forgot to mention that I need this for the latest developer version (Crypt-Rijndael-1.04_02). That's where the extra tests are :)

  • No solaris but I tried on linux sparc.
    All the tests passed but I got a few warnings.

    Rijndael.xs: In function 'XS_Crypt__Rijndael_new':
    Rijndael.xs:120: warning: pointer targets in passing argument 3 of 'rijndael_set up' differ in signedness
    Rijndael.xs: In function 'XS_Crypt__Rijndael_encrypt':
    Rijndael.xs:162: warning: pointer targets in passing argument 4 of '(ix) != 0l ?
  • Hey brian,

    I worked with you on getting Crypt::Rijndael to build on Solaris using the Sun Studio 10 C Compiler a while back so I figured I might part of your target audience. I'm not familiar with CPAN Testers (and don't have the time to familiarize myself with it right now), but I'm hoping this is still useful to you:

    [user@unixbox1:/home/user/temp/Crypt-Rijndael-1.04_02]> uname -a
    SunOS unixbox1 5.8 Generic_117350-49 sun4u sparc SUNW,Ultra-250
    [user@unixbox1:/home/user/temp]> gunzip -cd Crypt-Rijndael-
  • Unless you really need the speed, I go with pure Perl and avoid the issue completely. Have you benchmarked the difference?
    • BTW, all tests pass on Solaris 10 using Sun Studio compiler 12 and a 32-bit Perl. Here's minor patch #1:

      >diff -u _rijndael.orig _rijndael.c
      --- rijndael.orig       Fri Oct 12 14:00:48 2007
      +++ _rijndael.c Fri Oct 12 14:03:50 2007
      @@ -422,7 +422,7 @@
           e = wtxt[j] & 0xff;
           e |= (wtxt[idx[1][j]]) & (0xff << 8);
           e |= (wtxt[idx[2][j]]) & (0xff << 16);
      -    e |= (wtxt[idx[3][j]]) & (0xff << 24);

      • Good patch, applied to 1.04_03. Thanks. :)

        This also led me to figure out the other signedness warnings I've seen on some platforms. It compiles cleanly now (so far), but we'll see what the testers see now.

        Thanks,
  • You can download qemu images of Solaris10x86 or OpenSolaris from the Free OS Zoo at this link. Try your luck at converting qemu images to vmware format. http://www.oszoo.org/wiki/index.php/Special:Search?search=solaris&go=Go [oszoo.org] Cheers, Warren
  • PASS on Solaris 2.9 with gcc.