Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login | Reply
Loading... please wait.
  • Those two things have been the cause for a bunch of my modules recently. I don't bother trying to make anything work with 5.005 any more, so that's one problem. I've also gotten a rash of weird failures from testers where the failure was clearly a problem of their build environment. It'd be cool if testers could delete failure reports some how.
    • If your module was tested on 5.005, it's only because your Makefile.PL said (by omission) that it was compatible with 5.005.

      If your module DOESN'T support 5.005, then you should be reporting that.

      Then CPAN Testers won't test the module, and you won't accumulate FAIL reports.
      • A little bit of handholding would be much appreciated...

        Can you tell exactly what line we would need to add in Makefile.PL to achieve this?
        • Can you tell exactly what line we would need to add in Makefile.PL to achieve this?

          Just include use 5.006; and the toolchain will understand the distribution is not for pre-5.6 perls. Someone has said that this use was a 5.6 thing, but I've seen it work ok with 5.5. I don't know if even older perls would understand it as well or if they would need a more barroque thing like:

          BEGIN { require 5.006; }

          • If a dependency of a module is declared within the dependency to be incompatible with the perl version installing the module, does the installer get a warning during the typical "perl Makefile.pl; make; make test; make install"?