Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login | Reply
Loading... please wait.
  • "require 5;" - ??? - Is there *anyone* using Perl 4 any longer?
    • 1) Whether people use Perl 4 is irrelevent. What's important is that there are still a few crazy systems where "perl" is Perl 4. Some of my modules get installed in a lot of places, on machines of varying degrees of weirdness, by users of varying degrees of ability to diagnose things like when "perl" isn't Perl 5, unless given the explicit message from "require 5;" failing.

      2) Having the "require 5" there is a reminder to me that if I go using features like qr/.../, I should change the 5 to something like 5.005.