Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login | Reply
Loading... please wait.
  • I blame h2xs myself, for inserting the minimum version required into its default template. It's a very bad idea.

    -Dom

    • Unfortunately it's not just h2xs. Last time I trialed Module::Starter [cpan.org] and ExtUtils::ModuleMaker [cpan.org] they did it too. They both may have changed since then, but anyone who hasn't upgraded will still experience this.

      If anyone thinks they should include a specific version of Perl, then they should be running Perl::MinimumVersion [cpan.org] first to verify.

      I've lost count of the number of emails and bug reports I've sent to authors who don't realise that this gets set by default. If I started submitting reports again, a si