Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login | Reply
Loading... please wait.
  • Am I the only one who get errors during the 'make test' ?
    (on Linux Mandrake 8.1 box)

    I've thrown a fail report on the cpan-testers mailing list
    and got nothing except another version with the same error...

    As it's Schwern the author I'm seriously suspecting some goof from MY part.
    Any fail/pass report on this arch would be welcome...

    • Also on a Mandrake 8.1 box, I failed ExtUtils.t (24-25) and Manifest.t (25).

      ExtUtils.t wasn't adding the 'blib/lib' path. Adding that makes it succeed.

      It also looks like something was clobbering $@ in Manifest.t. Swapping lines 135 and 136 fixed it for me. There may be a missing local somewhere in Test::More or Test::Builder.

      All tests pass for me now though.

      • Yep ! I eventually decided that there might be a problem and investigated : I came to similar solutions an emailed them to Schwern.

        He sent me back a patch adding a "chdir 't' "for the first prob
        and said the second one would be fixed with Test::More 0.41 which isn't on CPAN yet...


        I think everything should be nice in the next version :-)

        Maybe it's a sign saying I should dare WRITING tests (rather to only check them)

        ;-)
        • Writing tests is good. You could even have some of Meestah Schwern's hard earned cash off him if you write new tests for bits of the core that are currently untested.

          /J\
    • > As it's Schwern the author I'm seriously suspecting some goof from MY part.

      HA! He don't know me very well, do he. I write lots of tests because I make lots of stupid mistakes. Unfortunately, some slipped by this time, which is fine as long as they don't slip by next time. ;)

      My mistake, for those keeping score, is I've been running the tests on perl which already has a new version of MakeMaker and Test::More and such installed. Thus goofs like not getting the @INC right or loading th

  • 5.48_04 available. (Score:3, Informative)

    by schwern (1528) on 2002.01.21 19:41 (#3486) Homepage Journal
    ExtUtils::MakeMaker 5.48_04 [pobox.com]

    Should fix what alis ya.