Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login | Reply
Loading... please wait.
  • Just in case I'm misinterpreting that output, it looks to me very much like Test::Class has a dependency which has upgraded to a broken version.

    This reminds me of two things I'd really like for CPAN to have:

    1. Ability to blacklist specific module versions, both in requirements (my module requires File::Next >= 1.0 and not 1.04, for example) and overall (effectively, we pull this version from the repository.)

    2. An option to install the test scripts for each module some place, and a script to re-run those

    • > 1. Ability to blacklist specific module versions, both in requirements
      > (my module requires File::Next >= 1.0 and not 1.04, for example) and
      > overall (effectively, we pull this version from the repository.)

      This one is certainly possible for non-configure_requires dependency, because we already have a turing-complete configuration phase. In pseudo code...

      if ( installed File::Next is 1.04 ) {
              requires File::Next 1.05
      } else {
              requires File::