Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

use Perl Log In

Log In

[ Create a new account ]

jonasbn (1153)

jonasbn
  reversethis-{gro.napc} {ta} {nbsanoj}
http://e-diot.dk/
AOL IM: BJonasN (Add Buddy, Send Message)

Perl Programmer located in Copenhagen, Denmark. Active member of Copenhagen Perl Mongers.

Author of:

  • Business::DK::CPR
  • Business::DK::CVR
  • Business::DK::PO
  • Business::OnlinePayment::CashCow
  • Date::Holidays
  • Date::Holidays::Abstract
  • Date::Holidays::Super
  • Date::Pregnancy
  • Games::Bingo
  • Games::Bingo::Bot
  • Games::Bingo::Print
  • Module::Info::File
  • Module::Template::Setup
  • Test::Timer

and maintainer of:

  • Tie::Tools
  • XML::Conf
  • Workflow

Journal of jonasbn (1153)

Thursday October 13, 2005
02:37 AM

Devel::Cover Trouble

[ #27144 ]

I have had several experiences where my unit-test suite passes, but Devel::Cover fails. I use the testcover target from Module::Build, but experienced the same problem when calling Devel::Cover in the conventional way.

I found this thread about the problem. But I am not complete convinced on how to proceed.

After getting test coverage to 98.6% on Business::OnlinePayment::CashCow I wanted to get high coverage on Date::Holidays aswell, since I was working on an update of this module.

This is the trouble some part

t/is_holiday......ok 11/12# Looks like your test died just after 12.
t/is_holiday......dubious
        Test returned status 255 (wstat 65280, 0xff00)
        after all the subtests completed successfully

Test 12, is the final test and nothing happens after that test - and the problem is probably in the actual module - hmmm...

The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login | Reply
Loading... please wait.