Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

use Perl Log In

Log In

[ Create a new account ]

jk2addict (4946)

jk2addict
  (email not shown publicly)
http://today.icantfocus.com/blog/
AOL IM: chrislaco (Add Buddy, Send Message)
Yahoo! ID: chrislaco@sbcglobal.net (Add User, Send Message)
Jabber: laco@scribblewerks.com

Journal of jk2addict (4946)

Friday October 26, 2007
10:00 AM

Very Strange Firefox Issue

[ #34756 ]

There's a long standing bug/feature with Firefox with input type=image elements where user has images turned off, or the image is 404ed, or just not loaded...when it's clicked, no x/y coords are sent to the server.

Just this week, we've had complaints from users getting an error on our site they shouldn't. As it turns out, they get the error because we check to make sure button.x and button.y have values...but firefox is passing them without values.

Now, for the odd part. This is happening to people who by all appearances, have the image loaded. My firefox 2/3 work just dandy, yet we have one internal user who gets the error (but the image is loaded via a provided screenshot).

I have no idea what the hell is going on, but it's damn strange. This is about as much fun as the other gecko bug I found in the old Compuserve7 version, where if you used javascript to hide a button after it was clicked, the browser for post literally sent Content-Length: 0.

The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login | Reply
Loading... please wait.
  • Is the form being submitted by pressing the enter key instead of clicking on the image map?
    • Nope. I tried that too. hitting enter when the button is highlighted works just fine.
      • What if the button isn't highlighted? Browsers are supposed to submit (simple) forms without needing to go near a submit button of any kind.
      • I lied. Good call.

        In Firefox 2.x, Return does indeed cause the issue as no x/y is sent. In Firefox 3.x, Return does not cause the issue, and it appears to send x/y.

        And the internal user who is having the problems... is clicking the button with a mouse, not hitting Return.

        This far, Firefox refused to fix the bug when no image was loaded, claiming that the image[map] might have more than on function when clicked. However, then they go ahead and fix the Return key in 3.x, which means they just broek their own
        • Faaaaaaaaarrrrrrrrrrgggg!!!!! Before I went to lunch, I couldn't reproduce it. Now that I'm back from lunch, CLICKING on the button in Fox 2.0.0.8 now does not send coords. W..T..F.