Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

use Perl Log In

Log In

[ Create a new account ]

chromatic (983)

chromatic
  (email not shown publicly)
http://wgz.org/chromatic/

Blog Information [technorati.com] Profile for chr0matic [technorati.com]

Journal of chromatic (983)

Monday March 30, 2009
02:24 PM

Test Reports from an Alternate Universe

[ #38726 ]

Allison asked me yesterday if a Parrot 1.0 failing CPAN Testers Report made sense. I had to say no.

If you read Slaven's report, you see that his installed version of TAP::Harness understands neither the verbosity nor the jobs flags. He's running Perl 5.10, released in December 2007.

The problem is that he's apparently using a beta version of TAP::Harness, as the first stable release (3.00, released in November 2007, before 5.10) understood at least the verbosity flag.

In other words, as best as I can determine, this smoker client represents a Perl 5.10 installation with unupgraded beta modules installed. I suggested to Allison that we ignore the report, as it's a weird configuration that only people who know what they're doing would ever encounter. I expect those people to be able to diagnose and fix these problems on their own.

The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login | Reply
Loading... please wait.