Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

use Perl Log In

Log In

[ Create a new account ]

ajt (2546)

ajt
  (email not shown publicly)
http://www.iredale.net/

UK based. Perl, XML/HTTP, SAP, Debian hacker.

  • CPAN: ATRICKETT [cpan.org]
  • PerlMonks: ajt [perlmonks.org]
  • Local LUG: AdamTrickett [lug.org.uk]
  • Debian Administration: ajt [debian-adm...ration.org]
  • LinkedIn: drajt [linkedin.com]

Journal of ajt (2546)

Sunday July 06, 2008
08:45 AM

Test Failures

[ #36859 ]

I'm getting some interesting test failures in my most recent revision of XML::RSS::Tools. Version 0.30 had some stupid errors in that I quickly fixed with version 0.31, I'm still getting some test failures but I can't replicate the problem.

I don't know if it's a bug in my code, my test or Test::Warn. Having more systems to help won't help per se (thanks for the previous offers) I need to figure out what is different about Perl 5.10.0 that works and Perl 5.10.0 that doesn't - the modules used in the tests even look the same...

The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login | Reply
Loading... please wait.
  • Thanks to help it looks like it's a bug in Test::Warn in how it interacts with Sub::Uplevel. There doesn't seem to be anything wrong with my code!

    --
    -- "It's not magic, it's work..."