Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

use Perl Log In

Log In

[ Create a new account ]

acme (189)

acme
  (email not shown publicly)
http://www.astray.com/

Leon Brocard (aka acme) is an orange-loving Perl eurohacker with many varied contributions to the Perl community, including the GraphViz module on the CPAN. YAPC::Europe was all his fault. He is still looking for a Perl Monger group he can start which begins with the letter 'D'.

Journal of acme (189)

Wednesday February 13, 2008
08:45 AM

JSON::XS::VersionOneAndTwo

[ #35646 ]
I've just released JSON::XS::VersionOneAndTwo:

JSON::XS is by far the best JSON module on the CPAN. However, it changed its API at version 2.01. If you have to maintain code which may be run on systems with either version one or two then this is a bit of a pain. This module takes the pain away without sacrificing performance.

The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login | Reply
Loading... please wait.
  • Nice! It's just too bad those 2 extra lines of code aren't included in the stock JSON::XS. Wouldn't have been that hard. :(
    • It's almost like I ranted about it on #london.pm and the result was:

      09:20 <@muttley> right, I've patched JSON::Any so it works out what version of
                       JSON::XS you have and DTRT
      09:22 <@acme> but i've just written JSON::XS::VersionOneAndTwo
      09:23 <@gellyfish> the more the merrier