Writing the pod parsing code is hurting my brain. Hopefully I'm almost done tho.
I'm going to wrap up all the really frightening low-level code that no-one should ever ever look at (as opposed to the higher-level stuff like the things that parse L<...> codes), in a package with a very ominous name. I'm torn between "BlackBox" (argument for: I get to use the quote: "What's in the box?" "Pain."; argument against: sounds like a testing unit) and "Nephron" (argument for: it's apropos: a nephron is a little-understood kind of microscopic structure in the kidneys that actually takes the blood stream and sorts the good stuff from the bad stuff; argument against: a bit obscure.)