Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

use Perl Log In

Log In

[ Create a new account ]

TorgoX (1933)

TorgoX
  sburkeNO@SPAMcpan.org
http://search.cpan.org/~sburke/

"Il est beau comme la retractilité des serres des oiseaux rapaces [...] et surtout, comme la rencontre fortuite sur une table de dissection d'une machine à coudre et d'un parapluie !" -- Lautréamont

Journal of TorgoX (1933)

Sunday February 17, 2002
12:53 PM

makepmdist

[ #2923 ]
Dear Log,

So, makepmdist seems to have gotten a nice bit of attention! I'm quite happy about that.

Many people have noticed the bug that a "package Foo;" statement isn't spotted if it's the first line in the file. I think this bug slipped out because I always start a .pm file with either a blank line or a sometimes "#!/bin/false" (so that if it's installed under a cgi-bin directory, it can't ever be run as a CGI -- altho that doesn't stop you from doing "perl Thing.pm"), and then a "require 5;", and then the "package Foo;" and whatnot. But I'm weird that way.

It's quite interesting to see how many people looked at makepmdist so quickly. It quite impressed me that people read the Perl mailing lists other than just when they get into the office on weekdays.

The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login | Reply
Loading... please wait.
  • "require 5;" - ??? - Is there *anyone* using Perl 4 any longer?
    • 1) Whether people use Perl 4 is irrelevent. What's important is that there are still a few crazy systems where "perl" is Perl 4. Some of my modules get installed in a lot of places, on machines of varying degrees of weirdness, by users of varying degrees of ability to diagnose things like when "perl" isn't Perl 5, unless given the explicit message from "require 5;" failing.

      2) Having the "require 5" there is a reminder to me that if I go using features like qr/.../, I should change the 5 to something li

  • you think we have lives on the weekend :)