Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

use Perl Log In

Log In

[ Create a new account ]

Alias (5735)

Alias
  (email not shown publicly)
http://ali.as/

Journal of Alias (5735)

Wednesday May 03, 2006
07:12 AM

Module::Install 0.62 upgrade advisory for authors

[ #29508 ]

I've just released Module::Install 0.62 to CPAN.

Because the 0.61 meant that Module::Install had basically become sane (no really) this release represents more a collection of small fixes, plus some prep work for the upcoming larger clean ups.

You could say that Module::Install isn't ready for heavy use by a lot of authors, but it doesn't do anything *actively* and universally fatal. The rest is just annoyances and structural problems that require a significant amount of work to fix (like the make-output overhaul planned by Matt Cashner, and the integration of the new "plays well with other" module Module::Install::With).

Of course, these changes won't alter the general design which remains sound, just fix implementation problems.

One of the currently open RT tickets contains the idea of an announce mailing list for Module::Install which would post an announcement for each release. More importantly, these announcements would contain recommendations on when authors should upgrade to the new release, and when it is not required.

So as an trial run, here are the 3 relevant upgrade notices for Module::Install 0.62.

As will be usual, when referencing "users" these generally *exclude* users installing using apt-get/rpm/etc and thus not running the Makefile.PL themselves.

----------------------------------------------------

1. Back-compatibility

M:I 0.62 contains fixes to two bugs which cause the installer to crash, uncovered during Module::ScanDeps back-compatibility testing.

One of these occurs when installing on systems with a perl *before* 5.6.3, and the other occurs on systems perl *before* 5.6.0.

Authors with signifigant users below 5.6.3 should consider an incremental release using 0.62.

2. The install_share command

The install_share command previously failed violently on older ExtUtils::MakeMaker versions. *All* distributions using install_share should be upgraded to 0.62.

3. Syntax and command changes

There are no changes or additionas to the syntax or commands in this release.

----------------------------------------------------

Any comments on thoughts you have on this sort of upgrade advisories would be greatly appreciated, so we can tune the releases to the most appropriate style.

The Fine Print: The following comments are owned by whoever posted them. We are not responsible for them in any way.
 Full
 Abbreviated
 Hidden
More | Login | Reply
Loading... please wait.