Stories
Slash Boxes
Comments
NOTE: use Perl; is on undef hiatus. You can read content, but you can't post it. More info will be forthcoming forthcomingly.

All the Perl that's Practical to Extract and Report

use Perl Log In

Log In

[ Create a new account ]

2shortplanks (968)

2shortplanks
  (email not shown publicly)
http://2shortplanks.com/
AOL IM: trelane2sp (Add Buddy, Send Message)
Yahoo! ID: trelane2sp (Add User, Send Message)

Mark Fowler has never been the same since he was elected leader of the London Perl Mongers. The strain manifests itself mainly in releasing various [cpan.org] modules [cpan.org] to CPAN, giving talks [2shortplanks.com], and use of the Trelane nick on #london.pm for endless procrastination. Doctors are still seeking a cure.
Thursday August 16, 2001
04:37 AM

Nothing works on this damn tank

[ #669 ]
Gah, technology hates me.

So not only did my laptop hard drive completely and irrevocably trash itself on the plane on the way back from YAPC::Europe, somebody stole my lucent gold card, CLIE and memory stick reader, but my work PC seems to have started to eating NICs and spitting them out broken. This doesn't happen to anyone else in the company you understand - I think I'm cursed. Hardware hates me: It's official.

But of course, it's not just hardware. Since I've been sans laptop this last week, at home mostly I've been using tigger. Tigger is acme's second laptop that he's been kind enough to lend to muttley and I for a bit, entrusting us not to completely trash it. So all was going fine until last night when instead of typing rm -r /usr/lib/mozilla I accidentally typed rm -r /usr/lib. Very messy. acme is a very understanding guy. Oh, and as a side note the Redhat install procedure is very nice these days isn't it. There's one for pdcawley's 12 step perl (well, it's not perl, but it's defiantly a bad one.)

Of course, it's not just limited to bash. I've been having real problems with POE recently, running on - you've guessed it - Windows. I've been trying to get POE::Wheel::SocketFactory to work, and while it works fine on Linux (and Windows 2000 apparently) it's just having none of it on WinNT, giving the helpful 10022 error (which apparently translates into the equally unhelpful Invalid Argument message.) The people on #poe have been very useful and understanding (I love the perl community) but as I know nada about Windows socket programming I can't really work out what the problem is. There's a post on the poe mailing list about it if you're interested.

Sigh.

On a positive note, spurned on by my success in getting Wireless working in the pub, I've invested in a larger aerial for the stuff which means I may or may not get involved with the whole consume thing. This all depends if my curse seems to lift in the near future - otherwise I'm going to end up falling off of the roof, I know it.